PDA

View Full Version : Wordpress bug?



the goat
10-20-2008, 10:00 PM
Well I don't know if it is a bug but it sure bugs me. Anyone else have the problem where you can't publish a post with two spaces anywhere in it. Even if I paste it from word by using the special "paste from word" icon it still erases the post anywhere after two spaces appear. No matter how often I ask them, the people that write for some of my sites always end up with two spaces after a few periods (and I don't blame them, it took forever to retrain myself).

I have been trying to search for answers, but figured I'd try the resident WP experts around here.

vangogh
10-21-2008, 04:32 PM
That's a new one to me. Are you using Safari as your browser. I found this at Wordpress support (http://wordpress.org/support/topic/142789) though it seems to only be Safari specific.

I realize this would be an extra step, but you could do a quick search and replace in Word or in a text editor to convert double spaces into single spaces before bringing the post into WP.

Another thought is to try the other view when publishing. If you use visual view try the html view, if you use html view try visual view. I'm not sure that will do anything, but it's worth a try and I've seen it solve other things.

I'll keep my eyes open about this and let you know if I find anything.

KristineS
10-21-2008, 04:57 PM
I've never heard of this, but then I don't really notice if I put two spaces after my punctuation on not. Actually, I just did after the end of the last sentence, so I guess I do. I write several Wordpress blogs and I've never encountered this issue.

the goat
10-21-2008, 05:02 PM
I appreciate in van gogh.

I don't use Safari, so it's not that. I have been able to find other people complaining about it, but no concrete answers yet:

WordPress › Support double spacing after a period (http://wordpress.org/support/topic/146121)

I was even able to find a plugin for it:

WordPress Plugin: Double-Space It! (http://www.bloggingpro.com/archives/2005/03/16/wordpress-plugin-double-space-it/)

Which leads me to believe it must be common, but still no solution to be found.

Bill Slawski
10-21-2008, 08:36 PM
There is one possible solution in the first of those links that you point towards, the goat.

If you set your option for "Encoding and feeds" to something other than "UTF-8," and your config.php file specifies that you are using UTF-8, then it could cause a problem like the one described.

Check to see what you have that set for, and you may be able to resolved the problem by either changing the Encoding to UTF-8, or by commenting out the use of UTF-8 in your config.php file.

the goat
10-21-2008, 09:25 PM
Thanks, I am not sure why I couldn't follow that from the link but the way you worded it made more sense to me. I put UTF-8 in the "encoding" and it worked like a charm.

Now I just need to figure out why every wordpress site I have isn't set to UTF-8.

vangogh
10-21-2008, 10:13 PM
Interesting Bill. I never would have thought of that, but sounds like it worked. Good to know for the future.

Bill Slawski
10-22-2008, 01:07 AM
I put UTF-8 in the "encoding" and it worked like a charm.

Great news!

I think most of the problems that I've had with WordPress have had a solution in the support forums, once you translate the answer into plain English. :)

vangogh
10-22-2008, 01:47 AM
I know what you mean about the support forums. I usually go to the codex first, but still often end up in the support forums. Sometimes there's nothing there that makes sense, but usually if I read the thread a few times and follow some of the links in it I get pointed in the right direction.